GetDotted Domains

Viewing Thread:
"Installing Linux for first time - dual boot problems"

The "Freeola Customer Forum" forum, which includes Retro Game Reviews, has been archived and is now read-only. You cannot post here or create a new thread or review on this forum.

Wed 13/04/05 at 23:53
Regular
"PC Gaming Founder"
Posts: 2,136
Yo people,

Currently trying to get Fedora Core 3 up-and-running on my machine. I've got a 400gb SATA running XP Pro and have today installed an 80gb SATA and successfully installed Fedora on it.

However, I'm having trouble configuring the machine for dual boot. I've set up the XP boot program (sorry, forgotten the name, begins with n, you know what I'm on about) so you can chose between XP and linux, but when I select linux the machine simply reboots. I'm guessing I've done something wrong when installing/setting up GRUB, but I'm not sure as I'm rather new to all this!

Any help would be greatly appreciated!
Fri 15/04/05 at 09:29
Regular
"bing bang bong"
Posts: 3,040
Your Linux installation is booting fine, but it seems to be broken. I thought you could view the files on your Linux distribution, you seemed to be able to reproduce your grub.conf :0S Try booting with your Fedora CD and typing "less /etc/fstab" minus the quotes to view that file.
Fri 15/04/05 at 00:12
Regular
"PC Gaming Founder"
Posts: 2,136
By the way, I changed it so that GRUB is in MBR, and using GRUB, it loads XP fine, but when trying to load FC3, I get exactly the same as result as doing the same thing with NTLDR.
Thu 14/04/05 at 23:21
Regular
"PC Gaming Founder"
Posts: 2,136
Miserableman wrote:
> What is the contents of your /etc/fstab file?

How do I go about viewing the contents of said file?
Thu 14/04/05 at 23:17
Regular
"bing bang bong"
Posts: 3,040
Are you sure Fedora is properly detecting that you have SATA drives? What is the contents of your /etc/fstab file?
Thu 14/04/05 at 19:53
Regular
"PC Gaming Founder"
Posts: 2,136
Ok, progress! Done the whole thing again and now when I select Linux using NTLDR, GRUB takes over, and FC3 starts to load, but then I get a load of nasty errors coming up:

Red Hat Nash version 4.1.18 starting
ata2 failed to respond
Reading all physical volumes. This may take a while...
No volume groups found
No volume groups found
No volume groups found
mount: error 6 mounting ext3
mount: error 2 mounting none
switchroot: mount failed: 22
umount /initrd/dev failed: 2
Kernel panic - not syncing: Attempted to kill init!

At which point nothing else happens. Any ideas chaps?
Thu 14/04/05 at 16:48
Regular
"PC Gaming Founder"
Posts: 2,136
Nimco wrote:
> I doubt it would be your graphics card. I didn't have drivers for my
> 9800XT at first, so instead it just uses software rendering - it
> still is doing in fact!

Ok, thanks for clearing that one up. :)
Thu 14/04/05 at 16:37
Regular
"NULL"
Posts: 1,384
I doubt it would be your graphics card. I didn't have drivers for my 9800XT at first, so instead it just uses software rendering - it still is doing in fact!
Thu 14/04/05 at 15:29
Regular
"PC Gaming Founder"
Posts: 2,136
Well I tried moving the Linux boot partition to the primary SATA as told to do so on that help page (involved installing Linux again, grr) but still the same result - computer reboots when I select Linux in NTLDR.

Just a thought, could it have anything to do with my ATI X800 XT card, as I hear Linux drivers for ATI cards are poor, and what with mine being the latest, that doesn't bode well.

I've got the FC3 DVD disc, which can load from boot, which is what I've been using to try and sort out this mess.

The contents of grub.conf, following the comments, is as follows:

default=0
timeout=5
splashimage=(hd1,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.9-1.667)
root (hd1,0)
kernel /vmlinuz-2.6.9-1.667 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
initrd /initrd-2.6.9-1.667.img
title Windows XP
rootnoverify(hd0,0)
chainloader +1

And boot.ini:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn
c:/linux.bin="Linux"

Please help! :(
Thu 14/04/05 at 14:20
Regular
"bing bang bong"
Posts: 3,040
Blimey-o'reilly, that's a mess of a method. I wonder why he didn't just let GRUB handle it all?

Do you have a boot disk of some description to get you into Linux? I think you're going to need one to get in and re-edit your grub.conf. If you don't have one, and you have broadband and a CD burner, you might want to download the excellent Knoppix ([URL]http://www.knoppix.org/[/URL]) which is a full Linux distribution on a CD - this will let you get into a Linux environment.

Do you know what the layout is of your disks, and the partitions on your disks? Something like:

Primary Master
First partition:Windows
Second partition:Music
Third partition:Network share

Primary Slave
CDRW drive

Secondary Master
First partition:Linux boot
Second partition:Linux swap
Third partition:Linux main

Secondary Slave
None


This information will be required when you come to set up grub.conf and/or boot.ini.

EDIT: oh, wait, I see you're using SATA drives. I'm going to have to get back to you.
Thu 14/04/05 at 13:46
Regular
"PC Gaming Founder"
Posts: 2,136
I've been using this help page:

[URL]http://www.geocities.com/epark/linux/grub-w2k-HOWTO.html[/URL]

Which looks to me as though it's using both GRUB and NTLDR, or am I mistaken?

On the page, near the top, it says if you're using multiple hard drives, the boot partition needs to be on the same hdd as windows, whereas currently mine is on the linux hdd. So I'm going to shrink my windows partition to make room for it on that hdd.

*has no idea what he's doing*

Freeola & GetDotted are rated

Check out some of our customer reviews below:

Just a quick note to say thanks for a very good service ... in fact excellent service..
I am very happy with your customer service and speed and quality of my broadband connection .. keep up the good work . and a good new year to all of you at freeola.
Matthew Bradley
I've been with Freeola for 14 years...
I've been with Freeola for 14 years now, and in that time you have proven time and time again to be a top-ranking internet service provider and unbeatable hosting service. Thank you.
Anthony

View More Reviews

Need some help? Give us a call on 01376 55 60 60

Go to Support Centre
Feedback Hide Feedback Tab

It appears you are using an old browser, as such, some parts of the Freeola and Getdotted site will not work as intended. Using the latest version of your browser, or another browser such as Google Chrome, Mozilla Firefox, or Opera will provide a better, safer browsing experience for you.